<!DOCTYPE html>
<!--[if lt IE 10 ]>
<html lang="en-US" prefix="og: http://ogp.me/ns#" class="old-ie no-js">
<![endif]-->
<!--[if !(IE 6) | !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US" prefix="og: http://ogp.me/ns#" class="no-js">
<!--<![endif]-->
<head>
	<meta charset="UTF-8" />
		<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1">
		<link rel="profile" href="http://gmpg.org/xfn/11" />
	<link rel="pingback" href="https://insidethepylon.com/xmlrpc.php" />
	<!--[if IE]>
	<script src="//html5shiv.googlecode.com/svn/trunk/html5.js"></script>
	<![endif]-->
	<title>Jeff Feyerer&#039;s 2018 Mock Draft - Inside The Pylon</title>
<script type="text/javascript">
function createCookie(a,d,b){if(b){var c=new Date;c.setTime(c.getTime()+864E5*b);b="; expires="+c.toGMTString()}else b="";document.cookie=a+"="+d+b+"; path=/"}function readCookie(a){a+="=";for(var d=document.cookie.split(";"),b=0;b<d.length;b++){for(var c=d[b];" "==c.charAt(0);)c=c.substring(1,c.length);if(0==c.indexOf(a))return c.substring(a.length,c.length)}return null}function eraseCookie(a){createCookie(a,"",-1)}
function areCookiesEnabled(){var a=!1;createCookie("testing","Hello",1);null!=readCookie("testing")&&(a=!0,eraseCookie("testing"));return a}(function(a){var d=readCookie("devicePixelRatio"),b=void 0===a.devicePixelRatio?1:a.devicePixelRatio;areCookiesEnabled()&&null==d&&(createCookie("devicePixelRatio",b,7),1!=b&&a.location.reload(!0))})(window);
</script>
<!-- This site is optimized with the Yoast SEO plugin v5.3.3 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="original-source" href="https://insidethepylon.com/nfl/2018-nfl-draft/2018/04/26/jeff-feyerers-2018-mock-draft/" />
<link rel="canonical" href="https://insidethepylon.com/nfl/2018-nfl-draft/2018/04/26/jeff-feyerers-2018-mock-draft/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Jeff Feyerer&#039;s 2018 Mock Draft - Inside The Pylon" />
<meta property="og:description" content="As I sat down to put the finishing touches on my final mock draft, my daughter spit up on my shoulder. After I put her down to clean up, I noticed the washing machine wasn’t running. After popping the lid, seeing the machine chock full of water and not draining while making a lovely buzzing&hellip;" />
<meta property="og:url" content="https://insidethepylon.com/nfl/2018-nfl-draft/2018/04/26/jeff-feyerers-2018-mock-draft/" />
<meta property="og:site_name" content="Inside The Pylon" />
<meta property="article:section" content="2018 NFL Draft" />
<meta property="article:published_time" content="2018-04-26T12:06:16-04:00" />
<meta property="og:image" content="https://cdn.insidethepylon.com/wp-content/uploads/2018/04/Bradley-Chubb-Feature.jpg" />
<meta property="og:image:secure_url" content="https://cdn.insidethepylon.com/wp-content/uploads/2018/04/Bradley-Chubb-Feature.jpg" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="800" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="As I sat down to put the finishing touches on my final mock draft, my daughter spit up on my shoulder. After I put her down to clean up, I noticed the washing machine wasn’t running. After popping the lid, seeing the machine chock full of water and not draining while making a lovely buzzing&hellip;" />
<meta name="twitter:title" content="Jeff Feyerer&#039;s 2018 Mock Draft - Inside The Pylon" />
<meta name="twitter:site" content="@ITPylon" />
<meta name="twitter:image" content="https://cdn.insidethepylon.com/wp-content/uploads/2018/04/Bradley-Chubb-Feature.jpg" />
<meta name="twitter:creator" content="@ITPylon" />
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"#website","url":"https:\/\/insidethepylon.com\/","name":"Inside The Pylon","potentialAction":{"@type":"SearchAction","target":"https:\/\/insidethepylon.com\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script>
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"Organization","url":"https:\/\/insidethepylon.com\/nfl\/2018-nfl-draft\/2018\/04\/26\/jeff-feyerers-2018-mock-draft\/","sameAs":["https:\/\/twitter.com\/ITPylon"],"@id":"#organization","name":"Inside The Pylon","logo":"http:\/\/cdn.insidethepylon.com\/wp-content\/uploads\/2015\/02\/itp-banner-newcolor1.png"}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//ssl.p.jwpcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Inside The Pylon &raquo; Feed" href="https://insidethepylon.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Inside The Pylon &raquo; Comments Feed" href="https://insidethepylon.com/comments/feed/" />
<link rel="alternate" type="text/calendar" title="Inside The Pylon &raquo; iCal Feed" href="https://insidethepylon.com/events/?ical=1" />
<link rel="alternate" type="application/rss+xml" title="Inside The Pylon &raquo; Jeff Feyerer&#8217;s 2018 Mock Draft Comments Feed" href="https://insidethepylon.com/nfl/2018-nfl-draft/2018/04/26/jeff-feyerers-2018-mock-draft/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/insidethepylon.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.5"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='theme-my-login-css'  href='https://insidethepylon.com/wp-content/plugins/theme-my-login/theme-my-login.css?ver=6.4.9' type='text/css' media='all' />
<link rel='stylesheet' id='layerslider-css'  href='https://insidethepylon.com/wp-content/plugins/LayerSlider/static/css/layerslider.css?ver=5.6.8' type='text/css' media='all' />
<link rel='stylesheet' id='ls-google-fonts-css'  href='https://fonts.googleapis.com/css?family=Lato:100,300,regular,700,900%7COpen+Sans:300%7CIndie+Flower:regular%7COswald:300,regular,700&#038;subset=latin%2Clatin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='https://insidethepylon.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=4.9' type='text/css' media='all' />
<link rel='stylesheet' id='go-pricing-styles-css'  href='https://insidethepylon.com/wp-content/plugins/go_pricing/assets/css/go_pricing_styles.css?ver=3.3.1' type='text/css' media='all' />
<link rel='stylesheet' id='et_monarch-open-sans-css'  href='https://fonts.googleapis.com/css?family=Open+Sans:400,700' type='text/css' media='all' />
<link rel='stylesheet' id='et_monarch-css-css'  href='https://insidethepylon.com/wp-content/plugins/monarch/css/style.css?ver=1.1.2' type='text/css' media='all' />
<link rel='stylesheet' id='tp_twitter_plugin_css-css'  href='https://insidethepylon.com/wp-content/plugins/recent-tweets-widget/tp_twitter_plugin.css?ver=1.0' type='text/css' media='screen' />
<link rel='stylesheet' id='rs-plugin-settings-css'  href='https://insidethepylon.com/wp-content/plugins/revslider/public/assets/css/settings.css?ver=5.2.5.2' type='text/css' media='all' />
<style id='rs-plugin-settings-inline-css' type='text/css'>
#rs-demo-id {}
</style>
<link rel='stylesheet' id='tablepress-default-css'  href='https://insidethepylon.com/wp-content/plugins/tablepress/css/default.min.css?ver=1.8' type='text/css' media='all' />
<link rel='stylesheet' id='dt-web-fonts-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A400%2C600%2C700&#038;ver=4.9.5' type='text/css' media='all' />
<link rel='stylesheet' id='dt-main-css'  href='https://insidethepylon.com/wp-content/themes/dt-the7/css/main.min.css?ver=3.7.1' type='text/css' media='all' />
<style id='dt-main-inline-css' type='text/css'>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</style>
<!--[if lt IE 10]>
<link rel='stylesheet' id='dt-old-ie-css'  href='https://insidethepylon.com/wp-content/themes/dt-the7/css/old-ie.css?ver=3.7.1' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='dt-awsome-fonts-css'  href='https://insidethepylon.com/wp-content/themes/dt-the7/fonts/FontAwesome/css/font-awesome.min.css?ver=3.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='dt-fontello-css'  href='https://insidethepylon.com/wp-content/themes/dt-the7/fonts/fontello/css/fontello.min.css?ver=3.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='style-css'  href='https://insidethepylon.com/wp-content/themes/dt-the7/style.css?ver=3.7.1' type='text/css' media='all' />
<style id='style-inline-css' type='text/css'>
/*breadcrumbs background color*/
.page-title .breadcrumbs {
background-color: rgba(0, 0, 0, 0.05);
}

a:link {
    text-decoration: none;
    font-weight: 900;
}

a:visited {
    text-decoration:  none;
    color:  #ff5544;
    font-weight:  900;
}

a:hover {
    text-decoration: underline;
    font-weight:  900;
}

a:active {
    text-decoration: underline;
}

h3 a:link, a:active {
   color: #ff5544 !important;
   font-weight:  900;
}

h4 a:link, a:active {
   color: #ff5544 !important;
   font-weight: 900;
}
h3 { 
   font-weight: 900;
}

h4 { 
   font-weight: 900;
}

</style>
<link rel='stylesheet' id='the7pt-static-css'  href='https://insidethepylon.com/wp-content/themes/dt-the7/css/post-type.css?ver=3.7.1' type='text/css' media='all' />
<!--[if lt IE 10]>
<link rel='stylesheet' id='dt-custom-old-ie.less-css'  href='https://insidethepylon.com/wp-content/uploads/wp-less/dt-the7/css/custom-old-ie-c580a32cc1.css?ver=3.7.1' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='dt-custom.less-css'  href='https://insidethepylon.com/wp-content/uploads/wp-less/dt-the7/css/custom-c580a32cc1.css?ver=3.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='dt-media.less-css'  href='https://insidethepylon.com/wp-content/uploads/wp-less/dt-the7/css/media-c580a32cc1.css?ver=3.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='the7pt.less-css'  href='https://insidethepylon.com/wp-content/uploads/wp-less/dt-the7/css/post-type-dynamic-c580a32cc1.css?ver=3.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='bsf-Defaults-css'  href='https://insidethepylon.com/wp-content/uploads/smile_fonts/Defaults/Defaults.css?ver=4.9.5' type='text/css' media='all' />
<link rel='stylesheet' id='cp-perfect-scroll-style-css'  href='https://insidethepylon.com/wp-content/plugins/convertplug/modules/slide_in/../../admin/assets/css/perfect-scrollbar.min.css?ver=4.9.5' type='text/css' media='all' />
<link rel='stylesheet' id='__EPYT__style-css'  href='https://insidethepylon.com/wp-content/plugins/youtube-embed-plus/styles/ytprefs.min.css?ver=4.9.5' type='text/css' media='all' />
<style id='__EPYT__style-inline-css' type='text/css'>

                .epyt-gallery-thumb {
                        width: 33.333%;
                }
                
</style>
<script type='text/javascript'>
/* <![CDATA[ */
var slide_in = {"demo_dir":"https:\/\/insidethepylon.com\/wp-content\/plugins\/convertplug\/modules\/slide_in\/assets\/demos"};
var smile_ajax = {"url":"https:\/\/insidethepylon.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://insidethepylon.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://insidethepylon.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://insidethepylon.com/wp-content/plugins/LayerSlider/static/js/greensock.js?ver=1.11.8'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var LS_Meta = {"v":"5.6.8"};
/* ]]> */
</script>
<script type='text/javascript' src='https://insidethepylon.com/wp-content/plugins/LayerSlider/static/js/layerslider.kreaturamedia.jquery.js?ver=5.6.8'></script>
<script type='text/javascript' src='https://insidethepylon.com/wp-content/plugins/LayerSlider/static/js/layerslider.transitions.js?ver=5.6.8'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/gsap/1.11.2/TweenMax.min.js?ver=3.3.1'></script>
<script type='text/javascript' src='https://ssl.p.jwpcdn.com/6/11/jwplayer.js?ver=4.9.5'></script>
<script type='text/javascript' src='https://insidethepylon.com/wp-content/plugins/revslider/public/assets/js/jquery.themepunch.tools.min.js?ver=5.2.5.2'></script>
<script type='text/javascript' src='https://insidethepylon.com/wp-content/plugins/revslider/public/assets/js/jquery.themepunch.revolution.min.js?ver=5.2.5.2'></script>
<script type='text/javascript' src='https://insidethepylon.com/wp-content/plugins/wp-hide-post/public/js/wp-hide-post-public.js?ver=2.0.10'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var dtLocal = {"themeUrl":"https:\/\/insidethepylon.com\/wp-content\/themes\/dt-the7","passText":"To view this protected post, enter the password below:","moreButtonText":{"loading":"Loading..."},"postID":"41797","ajaxurl":"https:\/\/insidethepylon.com\/wp-admin\/admin-ajax.php","contactNonce":"4b879d892a","ajaxNonce":"f06b84d3d0","pageData":"","themeSettings":{"smoothScroll":"off","lazyLoading":false,"accentColor":{"mode":"solid","color":"#ff5544"},"floatingHeader":{"showAfter":120,"showMenu":true,"height":70,"logo":{"showLogo":true,"html":"<img class=\" preload-me\" src=\"https:\/\/cdn.insidethepylon.com\/wp-content\/uploads\/2016\/07\/itp-banner-newcolor1-11.png\" srcset=\"https:\/\/cdn.insidethepylon.com\/wp-content\/uploads\/2016\/07\/itp-banner-newcolor1-11.png 350w\" width=\"350\" height=\"53\"   sizes=\"350px\" alt=\"Inside The Pylon\" \/>"}},"mobileHeader":{"firstSwitchPoint":500,"secondSwitchPoint":500},"content":{"responsivenessTreshold":970,"textColor":"#676b6d","headerColor":"#262b2e"},"stripes":{"stripe1":{"textColor":"#000000","headerColor":"#262b2e"},"stripe2":{"textColor":"#ffffff","headerColor":"#ffffff"},"stripe3":{"textColor":"#262b2e","headerColor":"#262b2e"}}}};
/* ]]> */
</script>
<script type='text/javascript' src='https://insidethepylon.com/wp-content/themes/dt-the7/js/above-the-fold.min.js?ver=3.7.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _EPYT_ = {"ajaxurl":"https:\/\/insidethepylon.com\/wp-admin\/admin-ajax.php","security":"167bb0b9ed","gallery_scrolloffset":"20","eppathtoscripts":"https:\/\/insidethepylon.com\/wp-content\/plugins\/youtube-embed-plus\/scripts\/","epresponsiveselector":"[\"iframe.__youtube_prefs_widget__\"]","epdovol":"1","version":"11.8.2","evselector":"iframe.__youtube_prefs__[src], iframe[src*=\"youtube.com\/embed\/\"], iframe[src*=\"youtube-nocookie.com\/embed\/\"]","ajax_compat":"","stopMobileBuffer":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://insidethepylon.com/wp-content/plugins/youtube-embed-plus/scripts/ytprefs.min.js?ver=4.9.5'></script>
<meta name="generator" content="Powered by LayerSlider 5.6.8 - Multi-Purpose, Responsive, Parallax, Mobile-Friendly Slider Plugin for WordPress." />
<!-- LayerSlider updates and docs at: https://kreaturamedia.com/layerslider-responsive-wordpress-slider-plugin/ -->
<link rel='https://api.w.org/' href='https://insidethepylon.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://insidethepylon.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://insidethepylon.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.9.5" />
<link rel='shortlink' href='https://insidethepylon.com/?p=41797' />
<link rel="alternate" type="application/json+oembed" href="https://insidethepylon.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Finsidethepylon.com%2Fnfl%2F2018-nfl-draft%2F2018%2F04%2F26%2Fjeff-feyerers-2018-mock-draft%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://insidethepylon.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Finsidethepylon.com%2Fnfl%2F2018-nfl-draft%2F2018%2F04%2F26%2Fjeff-feyerers-2018-mock-draft%2F&#038;format=xml" />

<!-- This site is using AdRotate v4.6.1 to display their advertisements - https://ajdg.solutions/products/adrotate-for-wordpress/ -->
<style type='text/css'>
</style>
<script type="text/javascript">jwplayer.key='f4PsSIDHZXng6G7PjTdBvq8sgayRnp+p8x/w1R2meXg=';jwplayer.defaults = { "ph": 2 };</script>
            <script type="text/javascript">
            if (typeof(jwp6AddLoadEvent) == 'undefined') {
                function jwp6AddLoadEvent(func) {
                    var oldonload = window.onload;
                    if (typeof window.onload != 'function') {
                        window.onload = func;
                    } else {
                        window.onload = function() {
                            if (oldonload) {
                                oldonload();
                            }
                            func();
                        }
                    }
                }
            }
            </script>

            <script type='text/javascript' data-cfasync='false'>var _mmunch = {'front': false, 'page': false, 'post': false, 'category': false, 'author': false, 'search': false, 'attachment': false, 'tag': false};_mmunch['post'] = true; _mmunch['postData'] = {"ID":41797,"post_name":"jeff-feyerers-2018-mock-draft","post_title":"Jeff Feyerer's 2018 Mock Draft","post_type":"post","post_author":"222","post_status":"publish"}; _mmunch['postCategories'] = [{"term_id":6517,"name":"2018 NFL Draft","slug":"2018-nfl-draft","term_group":0,"term_taxonomy_id":6588,"taxonomy":"category","description":"","parent":4,"count":88,"filter":"raw","cat_ID":6517,"category_count":88,"category_description":"","cat_name":"2018 NFL Draft","category_nicename":"2018-nfl-draft","category_parent":4}]; _mmunch['postTags'] = false; _mmunch['postAuthor'] = {"name":"Jeff Feyerer","ID":222};</script><script data-cfasync="false" src="//a.mailmunch.co/app/v1/site.js" id="mailmunch-script" data-plugin="mc_mm" data-mailmunch-site-id="183706" async></script><style type="text/css" id="et-social-custom-css">
				 
			</style><meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://insidethepylon.com"><link rel="https://theeventscalendar.com" href="https://insidethepylon.com/wp-json/tribe/events/v1/" /><meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="https://insidethepylon.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><!--[if IE  8]><link rel="stylesheet" type="text/css" href="https://insidethepylon.com/wp-content/plugins/js_composer/assets/css/vc-ie8.min.css" media="screen"><![endif]--><meta name="generator" content="Powered by Slider Revolution 5.2.5.2 - responsive, Mobile-Friendly Slider Plugin for WordPress with comfortable drag and drop interface." />
<meta name="google-site-verification" content="5EcKOGkUHKdEZl_soPU9RGRR6DZnekDFUwx2QeRPjZA" />
<meta name="google-site-verification" content="5EcKOGkUHKdEZl_soPU9RGRR6DZnekDFUwx2QeRPjZA" /><script type="text/javascript">
jQuery(function($) {
	var $window = $(window),
		$load = $("#load");
	
	$window.removeLoading = setTimeout(function() {
		$load.addClass("loader-removed").fadeOut(500);
	}, 500);
	
	$window.one("dt.removeLoading", function() {
		if (!$load.hasClass("loader-removed")) {
			clearTimeout($window.removeLoading);
			$("#load").addClass("loader-removed").fadeOut(500);
		}
	});
});
</script>
<!-- icon -->
<link rel="icon" href="http://cdn.insidethepylon.com/wp-content/uploads/2016/07/Logo-120.png" type="image/png" />
<link rel="shortcut icon" href="http://cdn.insidethepylon.com/wp-content/uploads/2016/07/Logo-120.png" type="image/png" />
<link rel="apple-touch-icon" href="http://cdn.insidethepylon.com/wp-content/uploads/2016/07/Logo-60.png">
<link rel="apple-touch-icon" sizes="76x76" href="http://cdn.insidethepylon.com/wp-content/uploads/2016/07/Logo-76.png">
<link rel="apple-touch-icon" sizes="120x120" href="http://cdn.insidethepylon.com/wp-content/uploads/2016/07/Logo-120.png">
<link rel="apple-touch-icon" sizes="152x152" href="http://cdn.insidethepylon.com/wp-content/uploads/2016/07/Logo-152.png">
<!-- BEGIN GADWP v5.1.1.1 Universal Analytics - https://deconf.com/google-analytics-dashboard-wordpress/ -->
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-47706240-4', 'auto');
  ga('send', 'pageview');
</script>
<!-- END GADWP Universal Analytics -->
<noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript></head>
<body class="post-template-default single single-post postid-41797 single-format-standard et_monarch tribe-no-js large-hover-icons click-effect-on-img srcset-enabled btn-material custom-btn-color custom-btn-hover-color filter-style-material contact-form-material large-fancy-datas accent-bullets bold-icons phantom-slide phantom-line-decoration phantom-custom-logo-on sticky-mobile-header top-header first-switch-logo-center first-switch-menu-left second-switch-logo-center second-switch-menu-left layzr-loading-on wpb-js-composer js-comp-ver-4.11.2.1 vc_responsive">
<br>
<div style="text-align:center">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Responsive Header -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-3474482334514396"
     data-ad-slot="9890609467"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
  </div>
<div id="load" class="spinner-loader">
	<div class="load-wrap"></div>
</div>
<div id="page">


<div class="masthead split-header outside widgets full-height shadow-decoration dt-parent-menu-clickable show-mobile-logo" role="banner">

			<div class="top-bar">
			<div class="mini-widgets"><div class="mini-login show-on-desktop near-logo-first-switch in-menu-second-switch"><a href="https://insidethepylon.com/my-account/" class="submit">Login</a></div></div>			<div class="mini-widgets"><div class="soc-ico show-on-desktop near-logo-first-switch hide-on-second-switch custom-bg hover-accent-bg"><a title="Facebook" href="https://www.facebook.com/insidethepylon" target="_blank" class="facebook"><span class="assistive-text">Facebook</span></a><a title="Twitter" href="https://twitter.com/ITPylon" target="_blank" class="twitter"><span class="assistive-text">Twitter</span></a><a title="SoundCloud" href="https://soundcloud.com/insidethepylon-podcast" target="_blank" class="soundcloud"><span class="assistive-text">SoundCloud</span></a></div><div class="mini-search show-on-desktop near-logo-first-switch near-logo-second-switch">	<form class="searchform" role="search" method="get" action="https://insidethepylon.com/">
		<input type="text" class="field searchform-s" name="s" value="" placeholder="Type and hit enter &hellip;" />
				<input type="submit" class="assistive-text searchsubmit" value="Go!" />
		<a href="#go" id="trigger-overlay" class="submit text-disable">&nbsp;</a>
	</form></div></div>		</div>
	<header class="header-bar">

						<div class="branding">

					<a href="https://insidethepylon.com/"><img class=" preload-me" src="https://cdn.insidethepylon.com/wp-content/uploads/2016/07/itp-banner-newcolor1-11.png" srcset="https://cdn.insidethepylon.com/wp-content/uploads/2016/07/itp-banner-newcolor1-11.png 350w, https://cdn.insidethepylon.com/wp-content/uploads/2016/07/itp-banner-newcolor1-1.png 350w" width="350" height="53"   sizes="350px" alt="Inside The Pylon" /><img class="mobile-logo preload-me" src="https://cdn.insidethepylon.com/wp-content/uploads/2016/07/ITPMobileBanner.png" srcset="https://cdn.insidethepylon.com/wp-content/uploads/2016/07/ITPMobileBanner.png 250w, https://cdn.insidethepylon.com/wp-content/uploads/2016/07/ITPMobileBanner.png 250w" width="250" height="38"   sizes="250px" alt="Inside The Pylon" /></a>
					<div id="site-title" class="assistive-text">Inside The Pylon</div>
					<div id="site-description" class="assistive-text">Know Football, Love Football</div>

					
					
				</div>
		<nav class="navigation">

			<ul class="main-nav underline-decoration from-centre-line" role="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30230 first"><a href='https://insidethepylon.com/nfl/' data-level='1'><span class="menu-item-text"><span class="menu-text">NFL</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30229"><a href='https://insidethepylon.com/cfb/' data-level='1'><span class="menu-item-text"><span class="menu-text">CFB</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30231"><a href='https://insidethepylon.com/football-term-glossary/' data-level='1'><span class="menu-item-text"><span class="menu-text">Glossary</span></span></a></li> </ul>
			
		</nav>

		<nav class="navigation">

			<ul class="main-nav underline-decoration from-centre-line" role="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-34635 first has-children"><a data-level='1'><span class="menu-item-text"><span class="menu-text">Listen/Watch</span></span></a><ul class="sub-nav level-arrows-on"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-30416 first has-children"><a href='https://insidethepylon.com/podcasts/' data-level='2'><span class="menu-item-text"><span class="menu-text">Podcasts</span></span></a><ul class="sub-nav level-arrows-on"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-34261 first"><a href='https://insidethepylon.com/breaking-plane-podcast/' data-level='3'><span class="menu-item-text"><span class="menu-text">Breaking the Plane</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-34266"><a href='https://insidethepylon.com/pylon-u-podcast/' data-level='3'><span class="menu-item-text"><span class="menu-text">Pylon U</span></span></a></li> </ul></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30284"><a href='https://insidethepylon.com/videos/' data-level='2'><span class="menu-item-text"><span class="menu-text">Videos</span></span></a></li> </ul></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-30236 has-children"><a href='https://insidethepylon.com/about-us/' data-level='1'><span class="menu-item-text"><span class="menu-text">About</span></span></a><ul class="sub-nav level-arrows-on"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30464 first"><a href='https://insidethepylon.com/about-us/' data-level='2'><span class="menu-item-text"><span class="menu-text">About</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30689"><a href='https://insidethepylon.com/authors/' data-level='2'><span class="menu-item-text"><span class="menu-text">Our Writers</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30310"><a href='https://insidethepylon.com/join-itp/' data-level='2'><span class="menu-item-text"><span class="menu-text">Join ITP</span></span></a></li> </ul></li> </ul>
			
		</nav>

	</header>

</div><div class='dt-close-mobile-menu-icon'><span></span></div>
<div class='dt-mobile-header'>
	<ul class="mobile-main-nav" role="menu">
		<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30272 first"><a href='https://insidethepylon.com/nfl/' data-level='1'><span class="menu-item-text"><span class="menu-text">NFL</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30271"><a href='https://insidethepylon.com/cfb/' data-level='1'><span class="menu-item-text"><span class="menu-text">CFB</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30270"><a href='https://insidethepylon.com/football-term-glossary/' data-level='1'><span class="menu-item-text"><span class="menu-text">Glossary</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30414"><a href='https://insidethepylon.com/podcasts/' data-level='1'><span class="menu-item-text"><span class="menu-text">Podcasts</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30268"><a href='https://insidethepylon.com/videos/' data-level='1'><span class="menu-item-text"><span class="menu-text">Video</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30267"><a href='https://insidethepylon.com/about-us/' data-level='1'><span class="menu-item-text"><span class="menu-text">About</span></span></a></li> 	</ul>
	<div class='mobile-mini-widgets-in-menu'></div>
</div>

		
	
		<div class="page-title content-left breadcrumbs-off" style="min-height: 140px;">
			<div class="wf-wrap">
				<div class="wf-container-title">
					<div class="wf-table" style="height: 140px;">

						<div class="wf-td hgroup"><h1 class="h1-size entry-title">Jeff Feyerer&#8217;s 2018 Mock Draft</h1></div>
					</div>
				</div>
			</div>
		</div>

		
	
	<div id="main" class="sidebar-right"><!-- class="sidebar-none", class="sidebar-left", class="sidebar-right" -->

		
		<div class="main-gradient"></div>
		<div class="wf-wrap">
			<div class="wf-container-main">

				<div class="article-top-bar "><div class="wf-wrap"><div class="wf-container-top"><div class="entry-meta"><a href="https://insidethepylon.com/2018/04/26/" title="12:06 pm" class="data-link" rel="bookmark"><time class="entry-date updated" datetime="2018-04-26T12:06:16+00:00">April 26, 2018</time></a><a href="https://insidethepylon.com/nfl/2018-nfl-draft/2018/04/26/jeff-feyerers-2018-mock-draft/#respond" class="comment-link" >Leave a comment</a><span class="category-link"><a href="https://insidethepylon.com/category/nfl/2018-nfl-draft/" >2018 NFL Draft</a></span><a class="author vcard" href="https://insidethepylon.com/author/jeffrey-feyerer/" title="View all posts by Jeff Feyerer" rel="author">By <span class="fn">Jeff Feyerer</span></a></div><div class="navigation-inner"><div class="single-navigation-wrap"><a class="prev-post" href="https://insidethepylon.com/nfl/teams-nfl/nfc-south/carolina-panthers/2018/04/26/carolina-panthers-2018-nfl-draft-plan/" rel="next"></a><a class="next-post" href="https://insidethepylon.com/nfl/2018-nfl-draft/2018/04/26/itps-final-2018-mock-draft/" rel="prev"></a></div></div></div></div></div>
	
		
			
			<!-- !- Content -->
			<div id="content" class="content" role="main">

				
<article id="post-41797" class="post-41797 post type-post status-publish format-standard has-post-thumbnail category-2018-nfl-draft description-off">

	
	
	<a href="https://cdn.insidethepylon.com/wp-content/uploads/2018/04/Bradley-Chubb-Feature.jpg" class="alignnone rollover rollover-zoom dt-single-mfp-popup dt-mfp-item mfp-image layzr-bg"  title="" data-dt-img-description="Bradley-Chubb-Feature"><img class="lazy-load preload-me" src="data:image/svg+xml;charset=utf-8,%3Csvg xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg' viewBox%3D'0 0 1200 800'%2F%3E" data-src="https://cdn.insidethepylon.com/wp-content/uploads/2018/04/Bradley-Chubb-Feature.jpg" data-srcset="https://cdn.insidethepylon.com/wp-content/uploads/2018/04/Bradley-Chubb-Feature.jpg 1200w" width="1200" height="800"  title="Bradley-Chubb-Feature" alt="" /></a><div class='mailmunch-forms-before-post' style='display: none !important;'></div><p><span style="font-weight: 400;"></p>
<div class="hr-thick"></div>
<p>As I sat down to put the finishing touches on my final mock draft, my daughter spit up on my shoulder. After I put her down to clean up, I noticed the washing machine wasn’t running. After popping the lid, seeing the machine chock full of water and not draining while making a lovely buzzing sound which I can only imagine is what #DraftTwitter sounds like this time of year at a certain frequency, I realized God may not want me to finish this. Heck, I’m just throwing it out there, but if God or whatever god you believe in knew we were spending time doing these types of things, I’m sure we’d all have some explaining to do.</span></p>
<p><span style="font-weight: 400;">This mock draft is what I think may come to pass on draft night. I’ve done my best to read the signals and ignore the noise. But I’m guessing a few minutes into the night, it will all be for naught. But still, they’re fun to look at. </span></p>
<p><span style="font-weight: 400;">Without further adieu, I give you the Cleveland Browns. Again.</span></p>
<h4><strong>1. Cleveland Browns &#8211; Sam Darnold/QB/USC </strong></h4>
<p><span style="font-weight: 400;">Like others, I refuse to believe Josh Allen is the pick until it actually happens. Darnold appears to have the makeup to deal with the ups and downs that could occur in Cleveland while also developing his game behind Tyrod Taylor in Year One. I would prefer Rosen here and understand the concerns about Darnold’s footwork, but truly believe he can be a franchise-type signal caller in this league.</span></p>
<p><span style="font-weight: 400;">I still leave the door open here for a surprise and the Browns pulling a “Draft Day” move and taking Chubb first when everyone expects the quarterback.</span></p>
<h4><strong>2. New York Giants &#8211; Saquon Barkley/RB/Penn State</strong></h4>
<p><span style="font-weight: 400;">If it was me in control of the board here, the pick would be Notre Dame’s Quenton Nelson given the team’s glaring holes still present on the offensive line. But this was a team in the playoffs just two years ago with a lot of the same talent in place and a transcendent talent at running back potentially falling into their lap. His versatility and game-breaking ability would add another dimension to the offense.</span></p>
<h4><strong>3. New York Jets &#8211; Josh Rosen/QB/UCLA</strong></h4>
<p><span style="font-weight: 400;">There is a lot of smoke out there right now about Baker Mayfield, but at the end of the day, I think Rosen will be the man getting his name called at the podium. I believe both players have the makeup to handle the bright lights of New York and each have their own unique questions about their character (both have been overblown), but if you’re going to make a mistake here, don’t you do it with the more traditional signal-caller “type” like Rosen who has an understanding of more advanced offensive systems? The Jets have invested heavily in the short-term at the position, but for the long-term Rosen is the man.</span></p>
<h4><strong>4. Cleveland Browns &#8211; Bradley Chubb/EDGE/North Carolina</strong></h4>
<p><span style="font-weight: 400;">Given what we just witnessed in Super Bowl 52 with the Eagles’ cadre of pass rushers relentlessly attacking Tom Brady, you can never have too many guys getting after the quarterback. Pairing Chubb up with Myles Garrett could be special as they have the potential to torment AFC North quarterbacks for years to come.</span></p>
<p><span style="font-weight: 400;">A trade down with a team pursuing a quarterback makes sense as well.</span></p>
<h4><strong>5. Buffalo Bills (trade #12, #53, #65 to DEN for #5) &#8211; Josh Allen/QB/Wyoming</strong></h4>
<p><span style="font-weight: 400;">John Elway has let it known he’s willing to deal. After adding Case Keenum in free agency and with a defense that remain stout, the Broncos are built to win now and may benefit from additional picks that could provide contributors instead of waiting on a quarterback. The Bills can move up here without relinquishing future first round picks and regardless of what you think about Allen, he has experience playing in elements similar to Buffalo and his strong arm will cut through whatever the wind throws at him. Let’s just hope for Bills fans sake there’s a receiver on their team close to the ball.</span></p>
<p><strong>6. Green Bay Packers (trade #14, #45, future 3rd for #6) &#8211;  Derwin James/S/Florida State</strong></p>
<p><span style="font-weight: 400;">New General Manager Brian Gutekunst makes a splash in his first draft following Ted Thompson’s retirement. The Packers don’t find themselves in the top half of the draft very often. With a team still built to compete as long as Aaron Rodgers is taking snaps, adding a playmaker on defense is a must. James would give new defensive coordinator Mike Pettine a versatile piece to combat opposing offenses.</span></p>
<h4><strong>7. Tampa Bay Buccaneers &#8211; Quenton Nelson/IOL/Notre Dame</strong></h4>
<p><span style="font-weight: 400;">My #1 player in the draft drops to 7 largely due to the position he plays, which is a mistake. The value of interior lineman is on the rise and Nelson is an elite talent who may be the best offensive guard to come around in decades. Protecting quarterback Jameis Winston is essential as well as opening up holes in the running game that just weren’t there last year.</span></p>
<h4><strong>8. Arizona Cardinals (trade #15, #47, future 3rd for #8) &#8211; Baker Mayfield/QB/Oklahoma</strong></h4>
<p><span style="font-weight: 400;">The Bears recoup additional picks they lost in their deals during last draft and the Cardinals get their quarterback of the future. Cardinals brass is said to be in love with Mayfield as they don’t miss the opportunity to pass up on a quarterback like they did last year. Another former Sooner Sam Bradford may start the season for the Cardinals, but Mayfield will be on his heels.</span></p>
<h4><strong>9. San Francisco 49ers &#8211; Minkah Fitzpatrick/S/Alabama</strong></h4>
<p><span style="font-weight: 400;">General Manager John Lynch knows the value in a safety being able to make plays at the line of scrimmage and in coverage because it’s exactly what he did as a player. Fitzpatrick played all over the field for Alabama and the bet is that he will do the same for the 49ers. He is my #2 player overall due to his superior instincts and playmaking ability. The concern about what is his position is shouldn’t be a problem. A good defensive coordinator will find a way to get the best out of the Tide star. </span></p>
<h4><strong>10. Oakland Raiders &#8211; Mike McGlinchey/OT/Notre Dame</strong></h4>
<p><span style="font-weight: 400;">A second Fighting Irish star enters the Top 10 and despite the weak offensive tackle class, he is worthy of this spot. He is stout in the run game, technically sound with the only concern some hiccups against speed rushers during his final year. McGlinchey could step in at left tackle for an aging Donald Penn or at right tackle where Vadal Alexander appears to be the only one blocking his path. </span></p>
<h4><strong>11. Miami Dolphins &#8211; Roquan Smith/LB/Georgia</strong></h4>
<p><span style="font-weight: 400;">Smith may have been the most impressive player in college football last season ranging from sideline to sideline each week. The Dolphins would love to add a player with that ability to pair with Kiko Alonso and last year’s second round pick Raekwon McMillan. I think a defensive back is a possibility here if James or Fitzpatrick were to drop, but Smith would be a tremendous value.</span></p>
<h4><strong>12. Denver Broncos (trade w/BUF) -Jaire Alexander/CB/Louisville</strong></h4>
<p><span style="font-weight: 400;">My #1 cornerback goes before most people’s #1 cornerback in a bit of a draft day surprise. Alexander’s risk-taking play style is reminiscent of the departed Aqib Talib. He struggled through injuries in 2017, but he’s a game who should play well along with Bradley Roby and Chris Harris.</span></p>
<h4><strong>13. Washington &#8211; Vita Vea/DL/Washington</strong></h4>
<p><span style="font-weight: 400;">Washington has bodies in the middle of the defensive line, but none with the potential of Vea. The run defense struggled mightily last year finishing last in yards allowed per game. Vea would help that while still showing the ability to develop into a three down lineman who can have an effect in the pass game too.</span></p><div class='mailmunch-forms-in-post-middle' style='display: none !important;'></div>
<h4><strong>14. Indianapolis Colts &#8211; Tremaine Edmunds/LB/Virginia Tech</strong></h4>
<p><span style="font-weight: 400;">General Manager Chris Ballard trades down with the Packers and still gets the guy he could have pegged at 6. At only 19 years old, Edmunds is years away from his peak as he has the chance to develop into the leader of the Colts defense. There will be growing pains as Edmunds isn’t as instinctual as Roquan Smith, but his combination of size and speed is reminiscent of Brian Urlacher.</span></p>
<h4><strong>15. Chicago Bears (trade w/ARZ) &#8211; Denzel Ward/CB/Ohio State</strong></h4>
<p><span style="font-weight: 400;">The Bears have slowly pieced together a solid young secondary. Adrian Amos has flashed, Eddie Jackson had a tremendous rookie season and after a rough 2016, Kyle Fuller had a comeback in 2017 and earned himself a huge contract. The last piece of the puzzle is Ward, who is the most technically sound cover cornerback in this year’s draft. Ohio State has a penchant for producing top tier defensive backs and Ward is no exception.</span></p>
<h4><strong>16. Baltimore Ravens &#8211; Lamar Jackson/QB/Louisville</strong></h4>
<p><span style="font-weight: 400;">General Manager Ozzie Newsome has done enough in his time in Baltimore that he doesn’t need to make a splash on the way out, but in this case he does. Jackson has the opportunity to succeed Joe Flacco while adding a new dimension to the Ravens offense. The doubt about Jackson’s ability at quarterback are unfounded as his progression throughout his college career in terms of refining his skills as a signal-caller was impressive.</span></p>
<h4><strong>17. Los Angeles Chargers &#8211; Isaiah Wynn/OT-OG/Georgia</strong></h4>
<p><span style="font-weight: 400;">The interior of the Chargers line has a chance to be one of the best in the league soon with 2017 rookies Dan Feeney and Forrest Lamp flanking offseason acquisition Mike Pouncey, but the tackles could be done soon. Russell Okung and Joe Barksdale are aging veterans and Wynn, despite some concerns about his height and ability to stick at tackle, is very much worthy of supplanting the two veterans.</span></p>
<h4><strong>18. Cleveland Browns (trade #33, #64, #114 to SEA for #18) &#8211; Derrius Guice/RB/LSU</strong></h4>
<p><span style="font-weight: 400;">The Browns miss out on Barkley, but they trade back up into the first round and snag a running back to compliment offseason acquisition Carlos Hyde. Browns advisor Scot McCloughan once proclaimed Guice to be better than Barkley. Time will tell, but more offensive playmakers are needed for the Browns and he is one. The Seahawks make the deal to recoup picks lost as they have only one pick in the Top 100.</span></p>
<h4><strong>19. Dallas Cowboys &#8211; Calvin Ridley/WR/Alabama</strong></h4>
<p><span style="font-weight: 400;">Goodbye, Dez Bryant! Hello, one of the best route runners to come into the draft in quite some time. Ridley struggled at the combine and his athleticism is a concern, but his style of play is eerily similar to Torry Holt and Marvin Harrison. He’s not going to outmuscle you, but he is refined, cunning and dependable. </span></p>
<h4><strong>20. Detroit Lions &#8211; Harold Landry/EDGE/Boston College</strong></h4>
<p><span style="font-weight: 400;">Throw on Landry’s 2016 tape and you see the reason I have him in my overall Top 10. Landry  would pair with Ezekiel Ansah to form a potentially devastating pass rush for the Lions, a plus when you’re going to play six games a year against Aaron Rodgers, Kirk Cousins and Mitch Trubisky for the foreseeable future.</span></p>
<h4><strong>21. Cincinnati Bengals &#8211; James Daniels/IOL/Iowa</strong></h4>
<p><span style="font-weight: 400;">With the depth of this year’s interior offensive line class, the Bengals will have a number of players available to fit their need. Daniels is the best athlete at the position, is fluid in getting to the second level in the run game and is a finisher. He will perhaps have to add strength, but jumping into in a NFL locker room will aid that.</span></p>
<h4><strong>22. Buffalo Bills &#8211; Frank Ragnow/IOL/Arkansas</strong></h4>
<p><span style="font-weight: 400;">With Eric Wood forced to retire in January due to a neck injury, the Bills lost their leader on the line. Ragnow would be a worthy replacement to succeed him. His leadership, intelligence and tenacity will be a welcome addition to the Buffalo line and he will have the chance to grow with Josh Allen.</span></p>
<h4><strong>23. New England Patriots &#8211; DJ Moore/WR/Maryland</strong></h4>
<p><span style="font-weight: 400;">It’s almost like Moore would be replacing what the team thought they were getting with Brandin Cooks, only cheaper. Moore really came on during the offseason lead up to the draft, but he is worthy of a spot in the first round. The Maryland offense largely relied simply on getting the ball in Moore’s hands on simple routes so he will need to continue to develop his route tree, but his explosiveness will be a nice addition to the New England offense.</span></p>
<h4><strong>24. Carolina Panthers &#8211; Marcus Davenport/EDGE/Texas-San Antonio</strong></h4>
<p><span style="font-weight: 400;">Wouldn’t it be nice for a guy built like Julius Peppers to serve as his understudy for a season? Davenport has incredible length and plays with aggression, but will need to refine his technique in order to become a consistent producer. </span></p>
<h4><strong>25. Tennessee Titans &#8211; Rashaan Evans/LB/Alabama</strong></h4>
<p><span style="font-weight: 400;">What better way to start the Mike Vrabel era than picking up a versatile linebacker like he was? There is a misconception that Evans is just a stack linebacker, but Alabama lined him all over, including as a pass rusher. The Titans will be able to deploy Evans in a variety of ways.</span></p>
<h4><strong>26. Atlanta Falcons &#8211; Da’Ron Payne/DL/Alabama</strong></h4>
<p><span style="font-weight: 400;">The only real question about Payne is whether or not the consistency will arrive. In the National Championship Game, it can be argued he was the best player on the field, which is saying something when you consider the number of future draft picks playing. Taven Bryan has many of the same questions regarding lack of production, but could be the pick here as well.</span></p>
<h4><strong>27. New Orleans Saints &#8211; Josh Sweat/EDGE/Florida State</strong></h4>
<p><span style="font-weight: 400;">With Cameron Jordan and Sheldon Rankins having the ability to bump inside on passing down, adding a pass rusher like Sweat would add another dimension to the defense. Sweat may be seen as a reach, but he has vaulted up board after the athletic testing and his production was very good at Florida State, despite not always being put in the right position to make plays. </span></p>
<h4><strong>28. Pittsburgh Steelers &#8211; Mike Hughes/CB/Central Florida</strong></h4>
<p><span style="font-weight: 400;">Hughes is a hard-nosed, physical player who can be a difference maker immediately. He’s going to be a factor in the run game and has shown the ability to make plays, but needs more top level experience and refinement of technique. Could a Roethlisberger replacement go here instead?</span></p>
<h4><strong>29. Jacksonville Jaguars &#8211; Courtland Sutton/WR/SMU</strong></h4>
<p><span style="font-weight: 400;">The Jaguars replace the departed Allen Robinson on the outside with another big receiver. Sutton has the potential to have the same impact Robinson did on the outside for the Jaguars and should be able to pair nicely with Marqise Lee, Dede Westbrook and Donte Moncrief. </span></p>
<h4><strong>30. Minnesota Vikings &#8211; Will Hernandez/IOL/UTEP</strong></h4>
<p><span style="font-weight: 400;">A year after drafting Pat Elflein, the Vikings continue to rebuild the line in front of new quarterback Kirk Cousins with an absolute mauler who will be busting up holes for 2017 rookie Dalvin Cook. Hernandez is both a brute and technician who, while lacking height, is a tremendous athlete for his size. </span></p>
<h4><strong>31. New England Patriots &#8211; Connor Williams/OT/Texas</strong></h4>
<p><span style="font-weight: 400;">I should preface this with the fact no one really knows what the Patriots are doing and what exactly is going on in Bill Belichick’s head. Does he really want a quarterback and is he willing to deal up to get one? Here, the Patriots replace Nate Solder with Williams, who despite having a down 2017, has the pure ability to be the anchor for an offensive line.</span></p>
<h4><strong>32. Philadelphia Eagles &#8211; Dallas Goedert/TE/South Dakota State</strong></h4>
<p><span style="font-weight: 400;">I wouldn’t call Goedert a symbolic choice, but so much of what we saw drive the Eagles’ success last year was the creativity and diversity of their offense. With both Brent Celek and Trey Burton leaving this offseason, that ability is disrupted. They’ve already added former Packers tight end Richard Rodgers, who would seemingly fit into the Celek role, but Goedert could form a devastating receiving duo with Zach Ertz.</span></p>
<span class="cp-load-after-post"></span></p><div class='mailmunch-forms-after-post' style='display: none !important;'></div><p></p>
	
	<div class="post-meta wf-mobile-collapsed"><div class="project-share-overlay allways-visible-icons"><a href="#" class="share-button entry-share h5-size">Share this post</a><div class="soc-ico"><a href="//www.facebook.com/sharer.php?m2w&#038;s=100&#038;p%5Burl%5D=https://insidethepylon.com/nfl/2018-nfl-draft/2018/04/26/jeff-feyerers-2018-mock-draft/&#038;p%5Bimages%5D%5B0%5D=https://cdn.insidethepylon.com/wp-content/uploads/2018/04/Bradley-Chubb-Feature.jpg&#038;p%5Btitle%5D=Jeff%20Feyerer&#039;s%202018%20Mock%20Draft" class="facebook" target="_blank" title="Facebook"><span class="assistive-text">Facebook</span></a><a href="https://twitter.com/home?status=Jeff%20Feyerer&#039;s%202018%20Mock%20Draft%20https://insidethepylon.com/nfl/2018-nfl-draft/2018/04/26/jeff-feyerers-2018-mock-draft/" class="twitter" target="_blank" title="Twitter"><span class="assistive-text">Twitter</span></a><a href="https://plus.google.com/share?url=https://insidethepylon.com/nfl/2018-nfl-draft/2018/04/26/jeff-feyerers-2018-mock-draft/&#038;title=Jeff+Feyerer&#039;s+2018+Mock+Draft" class="google" target="_blank" title="Google+"><span class="assistive-text">Google+</span></a></div></div></div>
	
		<div class="dt-fancy-separator title-left fancy-author-title">
			<div class="dt-fancy-title">About the author<span class="separator-holder separator-right"></span></div>
		</div>
		<div class="entry-author wf-table">
			<div class="wf-td entry-author-img"><img alt='' src='https://secure.gravatar.com/avatar/503bdedaa0ca8f2913653bf0b9b70309?s=85&#038;d=https%3A%2F%2Finsidethepylon.com%2Fwp-content%2Fthemes%2Fdt-the7%2Fimages%2Fno-avatar.gif&#038;r=g' srcset='https://secure.gravatar.com/avatar/503bdedaa0ca8f2913653bf0b9b70309?s=170&#038;d=https%3A%2F%2Finsidethepylon.com%2Fwp-content%2Fthemes%2Fdt-the7%2Fimages%2Fno-avatar.gif&#038;r=g 2x' class='alignleft avatar avatar-85 photo' height='85' width='85' /></div>			<div class="wf-td entry-author-info">
				<p class="h5-size">Jeff Feyerer</p>
				<p class="text-normal">Jeff Feyerer is currently a school district CFO living just outside Chicago.  Jeff's football experience includes draft and college football work for Ourlads.com, various coaching stints including Loyola University, marketing with the Houston Texans, and numerous writing projects dating back to his time at the University of Illinois. His football research interests include team building, asset diversification, the intersection of analytics and scouting, and the lost art of inside linebacker evaluation. Jeff has a Master's from Northern Illinois and divides his non-football/non-work time between his wife, son and his other sport, basketball.</p>
			</div>
		</div>

	
	<div class="dt-fancy-separator title-left fancy-posts-title"><div class="dt-fancy-title">Related posts<span class="separator-holder separator-right"></span></div></div><section class="items-grid wf-container"><div class="wf-cell wf-1-2"><div class="borders"><article class="post-format-standard"><div class="wf-td"><a class="alignleft post-rollover layzr-bg" href="https://insidethepylon.com/nfl/teams-nfl/nfc-south/carolina-panthers/2018/04/26/carolina-panthers-2018-nfl-draft-plan/" ><img class="lazy-load preload-me" src="data:image/svg+xml;charset=utf-8,%3Csvg xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg' viewBox%3D'0 0 80 60'%2F%3E" data-src="https://cdn.insidethepylon.com/wp-content/uploads/2018/04/Mike-McG-Feature.jpg" data-srcset="https://cdn.insidethepylon.com/wp-content/uploads/2018/04/Mike-McG-Feature.jpg 80w" width="80" height="60"  alt="" /></a></div><div class="post-content"><a href="https://insidethepylon.com/nfl/teams-nfl/nfc-south/carolina-panthers/2018/04/26/carolina-panthers-2018-nfl-draft-plan/">Carolina Panthers 2018 NFL Draft Plan</a><br /><time class="text-secondary" datetime="2018-04-26T12:15:30+00:00">April 26, 2018</time></div></article></div></div><div class="wf-cell wf-1-2"><div class="borders"><article class="post-format-standard"><div class="wf-td"><a class="alignleft post-rollover layzr-bg" href="https://insidethepylon.com/nfl/2018-nfl-draft/2018/04/26/itps-final-2018-mock-draft/" ><img class="lazy-load preload-me" src="data:image/svg+xml;charset=utf-8,%3Csvg xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg' viewBox%3D'0 0 80 60'%2F%3E" data-src="https://cdn.insidethepylon.com/wp-content/uploads/2017/10/Saquon-Barkley.jpg" data-srcset="https://cdn.insidethepylon.com/wp-content/uploads/2017/10/Saquon-Barkley.jpg 80w" width="80" height="60"  alt="" /></a></div><div class="post-content"><a href="https://insidethepylon.com/nfl/2018-nfl-draft/2018/04/26/itps-final-2018-mock-draft/">ITP&#8217;s Final 2018 Mock Draft</a><br /><time class="text-secondary" datetime="2018-04-26T11:49:56+00:00">April 26, 2018</time></div></article></div></div><div class="wf-cell wf-1-2"><div class="borders"><article class="post-format-standard"><div class="wf-td"><a class="alignleft post-rollover layzr-bg" href="https://insidethepylon.com/football-101/scouting/2018/04/26/joseph-ferraiolas-2018-nfl-draft-quarterback-rankings/" ><img class="lazy-load preload-me" src="data:image/svg+xml;charset=utf-8,%3Csvg xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg' viewBox%3D'0 0 80 60'%2F%3E" data-src="https://cdn.insidethepylon.com/wp-content/uploads/2017/08/Lamar-Jackson-Featured.jpg" data-srcset="https://cdn.insidethepylon.com/wp-content/uploads/2017/08/Lamar-Jackson-Featured.jpg 80w" width="80" height="60"  alt="" /></a></div><div class="post-content"><a href="https://insidethepylon.com/football-101/scouting/2018/04/26/joseph-ferraiolas-2018-nfl-draft-quarterback-rankings/">Joseph Ferraiola&#8217;s 2018 NFL Draft Quarterback Rankings</a><br /><time class="text-secondary" datetime="2018-04-26T09:00:08+00:00">April 26, 2018</time></div></article></div></div><div class="wf-cell wf-1-2"><div class="borders"><article class="post-format-standard"><div class="wf-td"><a class="alignleft post-rollover layzr-bg" href="https://insidethepylon.com/nfl/2018-nfl-draft/2018/04/25/clayton-smarslok-final-2018-nfl-mock-draft/" ><img class="lazy-load preload-me" src="data:image/svg+xml;charset=utf-8,%3Csvg xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg' viewBox%3D'0 0 80 60'%2F%3E" data-src="https://cdn.insidethepylon.com/wp-content/uploads/2018/04/Josh-Allen-feature.jpg" data-srcset="https://cdn.insidethepylon.com/wp-content/uploads/2018/04/Josh-Allen-feature.jpg 80w" width="80" height="60"  alt="" /></a></div><div class="post-content"><a href="https://insidethepylon.com/nfl/2018-nfl-draft/2018/04/25/clayton-smarslok-final-2018-nfl-mock-draft/">Clayton Smarslok Final 2018 NFL Mock Draft</a><br /><time class="text-secondary" datetime="2018-04-25T15:22:04+00:00">April 25, 2018</time></div></article></div></div><div class="wf-cell wf-1-2"><div class="borders"><article class="post-format-standard"><div class="wf-td"><a class="alignleft post-rollover layzr-bg" href="https://insidethepylon.com/football-101/scouting/2018/04/25/2018-nfl-draft-running-back-rankings-10-1/" ><img class="lazy-load preload-me" src="data:image/svg+xml;charset=utf-8,%3Csvg xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg' viewBox%3D'0 0 80 60'%2F%3E" data-src="https://cdn.insidethepylon.com/wp-content/uploads/2018/03/Derrius-Guice-Feature.jpg" data-srcset="https://cdn.insidethepylon.com/wp-content/uploads/2018/03/Derrius-Guice-Feature.jpg 80w" width="80" height="60"  alt="" /></a></div><div class="post-content"><a href="https://insidethepylon.com/football-101/scouting/2018/04/25/2018-nfl-draft-running-back-rankings-10-1/">2018 NFL Draft Running Back Rankings: 10-1</a><br /><time class="text-secondary" datetime="2018-04-25T13:41:27+00:00">April 25, 2018</time></div></article></div></div><div class="wf-cell wf-1-2"><div class="borders"><article class="post-format-standard"><div class="wf-td"><a class="alignleft post-rollover layzr-bg" href="https://insidethepylon.com/nfl/2018-nfl-draft/2018/04/25/check-round-one-quarterback-thoughts/" ><img class="lazy-load preload-me" src="data:image/svg+xml;charset=utf-8,%3Csvg xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg' viewBox%3D'0 0 80 60'%2F%3E" data-src="https://cdn.insidethepylon.com/wp-content/uploads/2017/09/Darnold.jpg" data-srcset="https://cdn.insidethepylon.com/wp-content/uploads/2017/09/Darnold.jpg 80w" width="80" height="60"  alt="HOSS Concept" /></a></div><div class="post-content"><a href="https://insidethepylon.com/nfl/2018-nfl-draft/2018/04/25/check-round-one-quarterback-thoughts/">Check With Me: Round One Quarterback Thoughts</a><br /><time class="text-secondary" datetime="2018-04-25T10:48:20+00:00">April 25, 2018</time></div></article></div></div></section>
	
	
</article><!-- #post-41797 -->
				

	<div id="comments" class="comments-area">
	
	
		
	
		<div class="dt-fancy-separator title-left fancy-comments-form">
			<div class="dt-fancy-title">Leave Comment<span class="separator-holder separator-right"></span></div>
		</div>

		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title"> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/nfl/2018-nfl-draft/2018/04/26/jeff-feyerers-2018-mock-draft/?src=rss#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="https://insidethepylon.com/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<p class="comment-notes text-small">Your email address will not be published. Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label class="assistive-text" for="comment">Comment</label><textarea id="comment" placeholder="Comment" name="comment" cols="45" rows="8" aria-required="true"></textarea></p><div class="form-fields"><span class="comment-form-author"><label class="assistive-text" for="author">Name &#42;</label><input id="author" name="author" type="text" placeholder="Name&#42;" value="" size="30" aria-required='true' /></span>
<span class="comment-form-email"><label class="assistive-text" for="email">Email &#42;</label><input id="email" name="email" type="text" placeholder="Email&#42;" value="" size="30" aria-required='true' /></span>
<span class="comment-form-url"><label class="assistive-text" for="url">Website</label><input id="url" name="url" type="text" placeholder="Website" value="" size="30" /></span></div>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <a href="javascript:void(0);" class="clear-form">clear form</a><a href="javascript:void(0);" class="dt-btn dt-btn-m"><span>Submit</span></a><input type='hidden' name='comment_post_ID' value='41797' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="5ca567d9bf" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="60"/></p>			</form>
			</div><!-- #respond -->
	
	</div><!-- #comments .comments-area -->

			</div><!-- #content .wf-cell -->

			
				<aside id="sidebar" class="sidebar">
					<div class="sidebar-content">
						<section id="search-5" class="widget widget_search"><div class="widget-title">Search</div>	<form class="searchform" role="search" method="get" action="https://insidethepylon.com/">
		<input type="text" class="field searchform-s" name="s" value="" placeholder="Type and hit enter &hellip;" />
		<input type="submit" class="assistive-text searchsubmit" value="Go!" />
		<a href="#go" class="submit"></a>
	</form></section><section id="text-8" class="widget widget_text">			<div class="textwidget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Responsive Sidebar -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-3474482334514396"
     data-ad-slot="7209609067"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
		</section><section id="presscore-blog-posts-2" class="widget widget_presscore-blog-posts"><div class="widget-title">Recent Posts</div><ul class="recent-posts round-images"><li><article class="post-format-standard"><div class="wf-td"><a class="alignleft post-rollover layzr-bg" href="https://insidethepylon.com/nfl/teams-nfl/nfc-south/carolina-panthers/2018/04/26/carolina-panthers-2018-nfl-draft-plan/" ><img class="lazy-load preload-me" src="data:image/svg+xml;charset=utf-8,%3Csvg xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg' viewBox%3D'0 0 40 40'%2F%3E" data-src="https://cdn.insidethepylon.com/wp-content/uploads/2018/04/Mike-McG-Feature.jpg" data-srcset="https://cdn.insidethepylon.com/wp-content/uploads/2018/04/Mike-McG-Feature.jpg 40w" width="40" height="40"  alt="" /></a></div><div class="post-content"><a href="https://insidethepylon.com/nfl/teams-nfl/nfc-south/carolina-panthers/2018/04/26/carolina-panthers-2018-nfl-draft-plan/">Carolina Panthers 2018 NFL Draft Plan</a><br /><time class="text-secondary" datetime="2018-04-26T12:15:30+00:00">April 26, 2018</time></div></article></li><li><article class="post-format-standard"><div class="wf-td"><a class="alignleft post-rollover layzr-bg" href="https://insidethepylon.com/nfl/2018-nfl-draft/2018/04/26/jeff-feyerers-2018-mock-draft/" ><img class="lazy-load preload-me" src="data:image/svg+xml;charset=utf-8,%3Csvg xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg' viewBox%3D'0 0 40 40'%2F%3E" data-src="https://cdn.insidethepylon.com/wp-content/uploads/2018/04/Bradley-Chubb-Feature.jpg" data-srcset="https://cdn.insidethepylon.com/wp-content/uploads/2018/04/Bradley-Chubb-Feature.jpg 40w" width="40" height="40"  alt="" /></a></div><div class="post-content"><a href="https://insidethepylon.com/nfl/2018-nfl-draft/2018/04/26/jeff-feyerers-2018-mock-draft/">Jeff Feyerer&#8217;s 2018 Mock Draft</a><br /><time class="text-secondary" datetime="2018-04-26T12:06:16+00:00">April 26, 2018</time></div></article></li><li><article class="post-format-standard"><div class="wf-td"><a class="alignleft post-rollover layzr-bg" href="https://insidethepylon.com/nfl/2018-nfl-draft/2018/04/26/itps-final-2018-mock-draft/" ><img class="lazy-load preload-me" src="data:image/svg+xml;charset=utf-8,%3Csvg xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg' viewBox%3D'0 0 40 40'%2F%3E" data-src="https://cdn.insidethepylon.com/wp-content/uploads/2017/10/Saquon-Barkley.jpg" data-srcset="https://cdn.insidethepylon.com/wp-content/uploads/2017/10/Saquon-Barkley.jpg 40w" width="40" height="40"  alt="" /></a></div><div class="post-content"><a href="https://insidethepylon.com/nfl/2018-nfl-draft/2018/04/26/itps-final-2018-mock-draft/">ITP&#8217;s Final 2018 Mock Draft</a><br /><time class="text-secondary" datetime="2018-04-26T11:49:56+00:00">April 26, 2018</time></div></article></li><li><article class="post-format-standard"><div class="wf-td"><a class="alignleft post-rollover layzr-bg" href="https://insidethepylon.com/football-101/scouting/2018/04/26/joseph-ferraiolas-2018-nfl-draft-quarterback-rankings/" ><img class="lazy-load preload-me" src="data:image/svg+xml;charset=utf-8,%3Csvg xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg' viewBox%3D'0 0 40 40'%2F%3E" data-src="https://cdn.insidethepylon.com/wp-content/uploads/2017/08/Lamar-Jackson-Featured.jpg" data-srcset="https://cdn.insidethepylon.com/wp-content/uploads/2017/08/Lamar-Jackson-Featured.jpg 40w" width="40" height="40"  alt="" /></a></div><div class="post-content"><a href="https://insidethepylon.com/football-101/scouting/2018/04/26/joseph-ferraiolas-2018-nfl-draft-quarterback-rankings/">Joseph Ferraiola&#8217;s 2018 NFL Draft Quarterback Rankings</a><br /><time class="text-secondary" datetime="2018-04-26T09:00:08+00:00">April 26, 2018</time></div></article></li><li><article class="post-format-standard"><div class="wf-td"><a class="alignleft post-rollover layzr-bg" href="https://insidethepylon.com/nfl/2018-nfl-draft/2018/04/25/clayton-smarslok-final-2018-nfl-mock-draft/" ><img class="lazy-load preload-me" src="data:image/svg+xml;charset=utf-8,%3Csvg xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg' viewBox%3D'0 0 40 40'%2F%3E" data-src="https://cdn.insidethepylon.com/wp-content/uploads/2018/04/Josh-Allen-feature.jpg" data-srcset="https://cdn.insidethepylon.com/wp-content/uploads/2018/04/Josh-Allen-feature.jpg 40w" width="40" height="40"  alt="" /></a></div><div class="post-content"><a href="https://insidethepylon.com/nfl/2018-nfl-draft/2018/04/25/clayton-smarslok-final-2018-nfl-mock-draft/">Clayton Smarslok Final 2018 NFL Mock Draft</a><br /><time class="text-secondary" datetime="2018-04-25T15:22:04+00:00">April 25, 2018</time></div></article></li><li><article class="post-format-standard"><div class="wf-td"><a class="alignleft post-rollover layzr-bg" href="https://insidethepylon.com/football-101/scouting/2018/04/25/2018-nfl-draft-running-back-rankings-10-1/" ><img class="lazy-load preload-me" src="data:image/svg+xml;charset=utf-8,%3Csvg xmlns%3D'http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg' viewBox%3D'0 0 40 40'%2F%3E" data-src="https://cdn.insidethepylon.com/wp-content/uploads/2018/03/Derrius-Guice-Feature.jpg" data-srcset="https://cdn.insidethepylon.com/wp-content/uploads/2018/03/Derrius-Guice-Feature.jpg 40w" width="40" height="40"  alt="" /></a></div><div class="post-content"><a href="https://insidethepylon.com/football-101/scouting/2018/04/25/2018-nfl-draft-running-back-rankings-10-1/">2018 NFL Draft Running Back Rankings: 10-1</a><br /><time class="text-secondary" datetime="2018-04-25T13:41:27+00:00">April 25, 2018</time></div></article></li></ul></section><section id="soundcloud_master_widget_advanced-5" class="widget SoundCloud Master Responsive"><div class="widget-title">Pylon U</div><div><iframe width="100%" height="450" scrolling="no" frameborder="no" src="https://w.soundcloud.com/player/?url=https://soundcloud.com/pylon-u-podcast&amp;hide_related=true&amp;visual=true&amp;color=ff5500&amp;auto_play=false&amp;show_artwork=true&amp;show_user=true&amp;show_comments=false&amp;show_playcount=true&amp;sharing=true&amp;liking=true&amp;download=false&amp;buying=false"></iframe></div></section><section id="monarchwidget-4" class="widget widget_monarchwidget"><div class="widget-title">Follow Us</div><div class="et_social_networks et_social_1col et_social_slide et_social_rectangle et_social_left et_social_mobile_on et_social_withnetworknames et_social_outer_dark widget_monarchwidget">
					
					
					<ul class="et_social_icons_container"><li class="et_social_twitter">
						<a href="https://twitter.com/ITPylon" class="et_social_follow" data-social_name="twitter" data-social_type="follow" data-post_id="41797" target="_blank">
							<i class="et_social_icon et_social_icon_twitter"></i>
							<div class="et_social_network_label"><div class="et_social_networkname">Twitter</div></div>
							<span class="et_social_overlay"></span>
						</a>
					</li><li class="et_social_facebook">
						<a href="https://www.facebook.com/insidethepylon" class="et_social_follow" data-social_name="facebook" data-social_type="follow" data-post_id="41797" target="_blank">
							<i class="et_social_icon et_social_icon_facebook"></i>
							<div class="et_social_network_label"><div class="et_social_networkname">Facebook</div></div>
							<span class="et_social_overlay"></span>
						</a>
					</li></ul>
				</div></section><section id="mc_mm_widget-3" class="widget widget_mc_mm_widget"><div class="widget-title">ITP Newsletter</div><div class='mailmunch-wordpress-widget mailmunch-wordpress-widget-248772' style='display: none !important;'></div></section><section id="text-24" class="widget widget_text">			<div class="textwidget"><script type="text/javascript">
amzn_assoc_placement = "adunit0";
amzn_assoc_enable_interest_ads = "true";
amzn_assoc_tracking_id = "insthepyl-20";
amzn_assoc_ad_mode = "auto";
amzn_assoc_ad_type = "smart";
amzn_assoc_marketplace = "amazon";
amzn_assoc_region = "US";
amzn_assoc_linkid = "e730dc520eb3fc99954c991dfe2a1fd2";
amzn_assoc_emphasize_categories = "3375251,3250697011";
amzn_assoc_fallback_mode = {"type":"search","value":"football"};
amzn_assoc_default_category = "All";
</script>
<script src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US"></script></div>
		</section>					</div>
				</aside><!-- #sidebar -->


		


			</div><!-- .wf-container -->
		</div><!-- .wf-wrap -->
	</div><!-- #main -->

	
	<!-- !Footer -->
	<footer id="footer" class="footer solid-bg">

		
			<div class="wf-wrap">
				<div class="wf-container-footer">
					<div class="wf-container">

								<section id="recent-posts-7" class="widget widget_recent_entries wf-cell wf-1-4">		<div class="widget-title">Recent Articles</div>		<ul>
											<li>
					<a href="https://insidethepylon.com/nfl/teams-nfl/nfc-south/carolina-panthers/2018/04/26/carolina-panthers-2018-nfl-draft-plan/">Carolina Panthers 2018 NFL Draft Plan</a>
									</li>
											<li>
					<a href="https://insidethepylon.com/nfl/2018-nfl-draft/2018/04/26/jeff-feyerers-2018-mock-draft/">Jeff Feyerer&#8217;s 2018 Mock Draft</a>
									</li>
											<li>
					<a href="https://insidethepylon.com/nfl/2018-nfl-draft/2018/04/26/itps-final-2018-mock-draft/">ITP&#8217;s Final 2018 Mock Draft</a>
									</li>
											<li>
					<a href="https://insidethepylon.com/football-101/scouting/2018/04/26/joseph-ferraiolas-2018-nfl-draft-quarterback-rankings/">Joseph Ferraiola&#8217;s 2018 NFL Draft Quarterback Rankings</a>
									</li>
					</ul>
		</section><section id="text-21" class="widget widget_text wf-cell wf-1-4"><div class="widget-title">About ITP</div>			<div class="textwidget"><a href="http://insidethepylon.com/about-us/">About</a>
<br>
<a href="/cdn-cgi/l/email-protection#fc9d988a998e88958f99bc95928f9598998894998c85909392d29f9391">Advertise</a>
<br>
<a href="/cdn-cgi/l/email-protection#70030411161630191e0319141504181500091c1f1e5e131f1d">Contact Us</a>
<br>
<a href="/cdn-cgi/l/email-protection#0a676f6e636b4a636479636e6f7e626f7a7366656424696567">Media Inquiries</a>
<br>
Press Room
<br>
<a href="/cdn-cgi/l/email-protection#3245405b4657725b5c415b5657465a57424b5e5d5c1c515d5f">Write for ITP</a></div>
		</section><section id="text-22" class="widget widget_text wf-cell wf-1-4"><div class="widget-title">Buy 17 Drives</div>			<div class="textwidget"><a href="https://www.amazon.com/dp/B01B54DVTG/ref=dp-kindle-redirect?_encoding=UTF8&btkr=1"><img width="150" style="margin: 7px 0px 0px 0px;max-width: 100%" src="http://cdn.insidethepylon.com/wp-content/uploads/2016/01/17DrivesFront.jpg"></a></div>
		</section><section id="monarchwidget-7" class="widget widget_monarchwidget wf-cell wf-1-4"><div class="widget-title">Follow Us</div><div class="et_social_networks et_social_1col et_social_slide et_social_rectangle et_social_left et_social_mobile_on et_social_withnetworknames et_social_outer_dark widget_monarchwidget">
					
					
					<ul class="et_social_icons_container"><li class="et_social_twitter">
						<a href="https://twitter.com/ITPylon" class="et_social_follow" data-social_name="twitter" data-social_type="follow" data-post_id="41797" target="_blank">
							<i class="et_social_icon et_social_icon_twitter"></i>
							<div class="et_social_network_label"><div class="et_social_networkname">Twitter</div></div>
							<span class="et_social_overlay"></span>
						</a>
					</li><li class="et_social_facebook">
						<a href="https://www.facebook.com/insidethepylon" class="et_social_follow" data-social_name="facebook" data-social_type="follow" data-post_id="41797" target="_blank">
							<i class="et_social_icon et_social_icon_facebook"></i>
							<div class="et_social_network_label"><div class="et_social_networkname">Facebook</div></div>
							<span class="et_social_overlay"></span>
						</a>
					</li></ul>
				</div></section>
					</div><!-- .wf-container -->
				</div><!-- .wf-container-footer -->
			</div><!-- .wf-wrap -->

		
<!-- !Bottom-bar -->
<div id="bottom-bar"  role="contentinfo">
	<div class="wf-wrap">
		<div class="wf-container-bottom">
			<div class="wf-table wf-mobile-collapsed">

				
				<div class="wf-td">

					
				</div>

				
			</div>
		</div><!-- .wf-container-bottom -->
	</div><!-- .wf-wrap -->
</div><!-- #bottom-bar -->
	</footer><!-- #footer -->



	<a href="#" class="scroll-top"></a>

</div><!-- #page -->
	            <script data-cfasync="false" src="/cdn-cgi/scripts/d07b1474/cloudflare-static/email-decode.min.js"></script><script type="text/javascript" id="modal">
				jQuery(window).load( function(){
					startclock();
				});
				function stopclock (){
				  if(timerRunning) clearTimeout(timerID);
				  timerRunning = false;
				  document.cookie="time=0";
				}
				function showtime () {
				  var now = new Date();
				  var my = now.getTime() ;
				  now = new Date(my-diffms) ;
				  document.cookie="time="+now.toLocaleString();
				  timerID = setTimeout('showtime()',10000);
				  timerRunning = true;
				}
				function startclock () {
				  stopclock();
				  showtime();
				}
				var timerID = null;
				var timerRunning = false;
				var x = new Date() ;
				var now = x.getTime() ;
				var gmt = 1524797727 * 1000 ;
				var diffms = (now - gmt) ;
				</script>
	            	            <script type="text/javascript" id="info-bar">
				jQuery(window).load( function(){
					startclock();
				});
				function stopclock (){
				  if(timerRunning) clearTimeout(timerID);
				  timerRunning = false;
				  document.cookie="time=0";
				}
				function showtime () {
				  var now = new Date();
				  var my = now.getTime() ;
				  now = new Date(my-diffms) ;
				  document.cookie="time="+now.toLocaleString();
				  timerID = setTimeout('showtime()',10000);
				  timerRunning = true;
				}
				function startclock () {
				  stopclock();
				  showtime();
				}
				var timerID = null;
				var timerRunning = false;
				var x = new Date() ;
				var now = x.getTime() ;
				var gmt = 1524797727 * 1000 ;
				var diffms = (now - gmt) ;
				</script>
	            	            <script type="text/javascript" id="slidein">
				jQuery(window).load( function(){
					startclock();
				});
				function stopclock (){
				  if(timerRunning) clearTimeout(timerID);
				  timerRunning = false;
				  document.cookie="time=0";
				}

				function showtime () {
				  var now = new Date();
				  var my = now.getTime() ;
				  now = new Date(my-diffms) ;
				  document.cookie="time="+now.toLocaleString();
				  timerID = setTimeout('showtime()',10000);
				  timerRunning = true;
				}

				function startclock () {
				  stopclock();
				  showtime();
				}
				var timerID = null;
				var timerRunning = false;
				var x = new Date() ;
				var now = x.getTime() ;
				var gmt = 1524797727 * 1000 ;
				var diffms = (now - gmt) ;
				</script>
	            		<script>
		( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );
		</script>
		<script type='text/javascript'> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done"}};/* ]]> */ </script><script type='text/javascript' src='https://insidethepylon.com/wp-content/themes/dt-the7/js/main.min.js?ver=3.7.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var click_object = {"ajax_url":"https:\/\/insidethepylon.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://insidethepylon.com/wp-content/plugins/adrotate/library/jquery.adrotate.clicktracker.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/insidethepylon.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://insidethepylon.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=4.9'></script>
<script type='text/javascript' src='https://insidethepylon.com/wp-content/plugins/go_pricing/assets/js/go_pricing_scripts.js?ver=3.3.1'></script>
<script type='text/javascript' src='https://insidethepylon.com/wp-content/plugins/monarch/js/ouibounce.js?ver=1.1.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var monarchSettings = {"ajaxurl":"https:\/\/insidethepylon.com\/wp-admin\/admin-ajax.php","pageurl":"https:\/\/insidethepylon.com\/nfl\/2018-nfl-draft\/2018\/04\/26\/jeff-feyerers-2018-mock-draft\/","stats_nonce":"fdf4e262b9","share_counts":"a326df014f","follow_counts":"8d87bac2b8","total_counts":"37cb42da5a","media_single":"5d2d8c4d86","media_total":"e3d50f9bad","no_img_message":"No images available for sharing on this page"};
/* ]]> */
</script>
<script type='text/javascript' src='https://insidethepylon.com/wp-content/plugins/monarch/js/custom.js?ver=1.1.2'></script>
<script type='text/javascript' src='https://insidethepylon.com/wp-content/plugins/js_composer/assets/js/frontend_editor/vendors/plugins/jwplayer.js?ver=1.0'></script>
<script type='text/javascript' src='https://insidethepylon.com/wp-includes/js/jquery/ui/effect.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://insidethepylon.com/wp-includes/js/jquery/ui/effect-fade.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://insidethepylon.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://insidethepylon.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://insidethepylon.com/wp-includes/js/jquery/ui/accordion.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://insidethepylon.com/wp-includes/js/jquery/ui/tabs.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://insidethepylon.com/wp-content/plugins/presso-shortcodes/js/presso-shortcodes.js?ver=VW_THEME_VERSION'></script>
<script type='text/javascript' src='https://insidethepylon.com/wp-includes/js/comment-reply.min.js?ver=4.9.5'></script>
<script type='text/javascript' src='https://insidethepylon.com/wp-content/themes/dt-the7/js/post-type.js?ver=3.7.1'></script>
<script type='text/javascript' src='https://insidethepylon.com/wp-content/plugins/youtube-embed-plus/scripts/fitvids.min.js?ver=4.9.5'></script>
<script type='text/javascript' src='https://insidethepylon.com/wp-includes/js/wp-embed.min.js?ver=4.9.5'></script>
<script type='text/javascript' src='https://insidethepylon.com/wp-content/plugins/akismet/_inc/form.js?ver=3.3.4'></script>
</body>
</html>